Zurück zur Homepage

Beep

Formelbeep oder Funktionsbeep.
Die Formel funzt nur unter XL97 ohne Sicherheitspatch. Wenn eine Soundkarte installiert ist, wird der Standardsound aus den WIN-Einstellungen benutzt. Übrigens sind die Formeln gefährlich: Auch wenn die Makroausführung gesperrt ist, werden die Formeln ausgeführt. Es lassen sich alle möglichen bösen Sachen damit anstellen, angefangen beim Starten externer Programme. Das Thema will ich aus verständlichen Gründen aber hier nicht weiter vertiefen.

Beispieldatei (beep.zip 9 kB)

 Private Declare Function piep& Lib "kernel32" Alias "Beep" (ByVal dwFrequenz As Long, ByVal dwDauer As Long)

 Public Function piepsen(Frequenz As Long, Dauer_Millisec As Long)
  piepsen = ""
  piep Frequenz, Dauer_Millisec
End Function

D29=Frequenz , D30=Dauer in Millisekunden, Piepsen bei Neuberechnung und Änderung in B29

=WENN(AUFRUFEN("kernel32";"Beep";"1JJ";D29;D30)=B29;"Formel";"Formel")